summaryrefslogtreecommitdiffstats
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
authorM. Remy <mremy@gmx.ch>2012-04-17 20:15:15 (GMT)
committerHolger Weiss <holger@zedat.fu-berlin.de>2012-06-07 08:14:16 (GMT)
commit3e622f3a47bc7d31f22513a79892c3c52febd2d3 (patch)
tree75df841b5d21b36cd869a574e7857ec6a49fb6ae /plugins/Makefile.am
parent679a2296065893fd428891d610499c04a50aaa29 (diff)
downloadmonitoring-plugins-3e622f3a47bc7d31f22513a79892c3c52febd2d3.tar.gz
check_users: improve performance
This patch use the utxent function family to collect the user data. It improve the check speed. Need a system conforming to POSIX.1-2001.
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index 36a28b0..3a2afc1 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -101,7 +101,7 @@ check_tcp_LDADD = $(SSLOBJS) $(NETLIBS) $(SSLLIBS)
101check_time_LDADD = $(NETLIBS) 101check_time_LDADD = $(NETLIBS)
102check_ntp_time_LDADD = $(NETLIBS) $(MATHLIBS) 102check_ntp_time_LDADD = $(NETLIBS) $(MATHLIBS)
103check_ups_LDADD = $(NETLIBS) 103check_ups_LDADD = $(NETLIBS)
104check_users_LDADD = $(BASEOBJS) popen.o 104check_users_LDADD = $(BASEOBJS)
105check_by_ssh_LDADD = $(NETLIBS) 105check_by_ssh_LDADD = $(NETLIBS)
106check_ide_smart_LDADD = $(BASEOBJS) 106check_ide_smart_LDADD = $(BASEOBJS)
107negate_LDADD = $(BASEOBJS) 107negate_LDADD = $(BASEOBJS)