summaryrefslogtreecommitdiffstats
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
authorTon Voon <tonvoon@users.sourceforge.net>2003-03-08 01:59:31 (GMT)
committerTon Voon <tonvoon@users.sourceforge.net>2003-03-08 01:59:31 (GMT)
commit8b6d3138337997b266720518c7b0dfd42462f482 (patch)
tree0701345fe1296e53a23693115d4461d8fae8972b /plugins/Makefile.am
parent1f96af37e3c4396e10d39239928c689ea5d0a9a1 (diff)
downloadmonitoring-plugins-8b6d3138337997b266720518c7b0dfd42462f482.tar.gz
Move snprintf into lib
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@382 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am9
1 files changed, 1 insertions, 8 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index 851745a..bd5b550 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -16,8 +16,7 @@ EXTRA_PROGRAMS = check_mysql check_radius check_pgsql check_snmp check_hpjd \
16 16
17check_tcp_programs = check_ftp check_imap check_nntp check_pop 17check_tcp_programs = check_ftp check_imap check_nntp check_pop
18 18
19EXTRA_DIST = t utils.c netutils.c popen.c \ 19EXTRA_DIST = t utils.c netutils.c popen.c
20 snprintf.c
21 20
22PLUGINHDRS = common.h config.h 21PLUGINHDRS = common.h config.h
23 22
@@ -118,12 +117,6 @@ utils.o: utils.c utils.h $(PLUGINHDRS)
118 117
119netutils.o: netutils.c netutils.h $(PLUGINHDRS) 118netutils.o: netutils.c netutils.h $(PLUGINHDRS)
120 119
121snprintf.o: snprintf.c
122 $(COMPILE) @NEED_VA_LIST@ -c $(srcdir)/snprintf.c -o $@
123
124libsnprintf.a: snprintf.o
125 $(AR) -r $@ snprintf.o
126
127all-local: $(check_tcp_programs) 120all-local: $(check_tcp_programs)
128 121
129$(check_tcp_programs): check_tcp 122$(check_tcp_programs): check_tcp