summaryrefslogtreecommitdiffstats
path: root/plugins/uriparser/Makefile.am
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2017-05-06 14:36:16 (GMT)
committerAndreas Baumann <mail@andreasbaumann.cc>2017-05-06 14:36:16 (GMT)
commit19bd8afa6b63dccadc2006292154f1633e2a29c9 (patch)
tree1677f5a2b3caccce45a75fc6ca5857a7d820686c /plugins/uriparser/Makefile.am
parent4b2800f8f3ee34d9779dfdcd40d7e68b569380e6 (diff)
downloadmonitoring-plugins-19bd8afa6b63dccadc2006292154f1633e2a29c9.tar.gz
some rework:
- added old style 'redir' function and options along to a new libcurl internal 'follow' parameter 'curl' - moved picohttpparser to it's own subdirectory - added uriparser to be used instead of the home-grown parser in 'redir'
Diffstat (limited to 'plugins/uriparser/Makefile.am')
-rw-r--r--plugins/uriparser/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/plugins/uriparser/Makefile.am b/plugins/uriparser/Makefile.am
new file mode 100644
index 0000000..592e694
--- /dev/null
+++ b/plugins/uriparser/Makefile.am
@@ -0,0 +1,9 @@
1noinst_LIBRARIES = liburiparser.a
2
3liburiparser_a_SOURCES = UriCommon.c UriCompare.c \
4 UriEscape.c UriFile.c UriIp4.c \
5 UriIp4Base.c UriNormalize.c \
6 UriNormalizeBase.c UriParse.c \
7 UriParseBase.c UriQuery.c \
8 UriRecompose.c UriResolve.c \
9 UriShorten.c