summaryrefslogtreecommitdiffstats
path: root/tap/Makefile.am
diff options
context:
space:
mode:
authorThomas Guyot-Sionnest <dermoth@aei.ca>2008-11-28 10:01:53 (GMT)
committerThomas Guyot-Sionnest <dermoth@aei.ca>2008-11-29 09:38:54 (GMT)
commit2bbf2e6967daa0a9f86874aac409fde245a3bc85 (patch)
tree7fc7a9e96f3bc0e1b6749cbd999c93a292e0d12b /tap/Makefile.am
parent538b97cea63d68efbd9c9c67d9c41278cfd1ebad (diff)
downloadmonitoring-plugins-2bbf2e6967daa0a9f86874aac409fde245a3bc85.tar.gz
Add Libtap as a bundled library (does not change any behaviour without --enable-libtap)
Detects system library as pre-1.4.13 and does not install the built-in library anymore Tested on: - Linux x86_64, with and without local libtap (System libtap installed) - Linux x86, with and without local libtap (System libtap NOT installed) - Solaris SPARC, with and without local libtap, with and without system libtap installed
Diffstat (limited to 'tap/Makefile.am')
-rw-r--r--tap/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/tap/Makefile.am b/tap/Makefile.am
new file mode 100644
index 0000000..86147c5
--- /dev/null
+++ b/tap/Makefile.am
@@ -0,0 +1,13 @@
1# Tap self-tests are not implemented (yet?)
2# SUBDIRS = tests
3
4if USE_LIBTAP_LOCAL
5noinst_LTLIBRARIES = libtap.la
6libtap_la_SOURCES = tap.c tap.h
7include_HEADERS = tap.h
8endif USE_LIBTAP_LOCAL
9
10# see top comment
11#prove:
12# prove -v -r
13