summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 2 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 7032578..a0bc561 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,16 +1,14 @@
1## Process this file with automake to produce Makefile.in 1## Process this file with automake to produce Makefile.in
2 2
3SUBDIRS = gl @INCLUDE_TAP_DIR@ lib plugins plugins-scripts plugins-root po @PERLMODS_DIR@ 3SUBDIRS = gl lib plugins plugins-scripts plugins-root po @PERLMODS_DIR@
4 4
5# Have to list TAP_DIR manually to get in distribution
6EXTRA_DIST = config.rpath \ 5EXTRA_DIST = config.rpath \
7 ABOUT-NLS ACKNOWLEDGEMENTS AUTHORS BUGS CODING FAQ LEGAL NEWS \ 6 ABOUT-NLS ACKNOWLEDGEMENTS AUTHORS BUGS CODING FAQ LEGAL NEWS \
8 NP-VERSION-GEN REQUIREMENTS SUPPORT THANKS \ 7 NP-VERSION-GEN REQUIREMENTS SUPPORT THANKS \
9 NPTest.pm contrib pkg nagios-plugins.spec \ 8 NPTest.pm contrib pkg nagios-plugins.spec \
10 config_test/Makefile config_test/run_tests config_test/child_test.c \ 9 config_test/Makefile config_test/run_tests config_test/child_test.c \
11 perlmods tools/build_perl_modules \ 10 perlmods tools/build_perl_modules \
12 tools/tinderbox_build \ 11 tools/tinderbox_build
13 external/tap-1.01
14 12
15ACLOCAL_AMFLAGS = -I gl/m4 -I m4 13ACLOCAL_AMFLAGS = -I gl/m4 -I m4
16 14
@@ -24,9 +22,6 @@ dist-hook:
24install-root: 22install-root:
25 cd plugins-root && $(MAKE) $@ 23 cd plugins-root && $(MAKE) $@
26 24
27tap:
28 cd @TAP_DIR@ && $(MAKE)
29
30test test-debug: 25test test-debug:
31 cd lib && $(MAKE) $@ 26 cd lib && $(MAKE) $@
32 if test "$(PERLMODS_DIR)" != ""; then cd perlmods && $(MAKE) $@; fi 27 if test "$(PERLMODS_DIR)" != ""; then cd perlmods && $(MAKE) $@; fi