summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f405cce..244df42 100644
--- a/configure.ac
+++ b/configure.ac
@@ -364,8 +364,16 @@ dnl Check for headers used by check_users
364AC_CHECK_HEADERS(utmpx.h) 364AC_CHECK_HEADERS(utmpx.h)
365AM_CONDITIONAL([HAVE_UTMPX], [test "$ac_cv_header_utmpx_h" = "yes"]) 365AM_CONDITIONAL([HAVE_UTMPX], [test "$ac_cv_header_utmpx_h" = "yes"])
366 366
367AC_CHECK_HEADERS(wtsapi32.h, [], [], [#include <windows.h>])
368AM_CONDITIONAL([HAVE_WTS32API], [test "$ac_cv_header_wtsapi32_h" = "yes"])
369
370if test "$ac_cv_header_wtsapi32_h" = "yes"; then
371 WTSAPI32LIBS="-lwtsapi32"
372 AC_SUBST(WTSAPI32LIBS)
373fi
374
367dnl Fallback to who(1) if the system doesn't provide an utmpx(5) interface 375dnl Fallback to who(1) if the system doesn't provide an utmpx(5) interface
368if test "$ac_cv_header_utmpx_h" = "no" 376if test "$ac_cv_header_utmpx_h" = "no" -a "$ac_cv_header_wtsapi32_h" = "no"
369then 377then
370 AC_PATH_PROG(PATH_TO_WHO,who) 378 AC_PATH_PROG(PATH_TO_WHO,who)
371 379