summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 59875e5..6dacd4f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -544,6 +544,18 @@ else
544 with_gnutls="no" 544 with_gnutls="no"
545fi 545fi
546 546
547dnl Check for POSIX thread libraries
548AC_CHECK_HEADERS(pthread.h)
549case $host in
550 *sun* | *solaris*)
551 AC_CHECK_LIB(pthread,pthread_create,THRLIBS="-lpthread -lrt")
552 ;;
553 *)
554 AC_CHECK_LIB(pthread,pthread_create,THRLIBS="-lpthread")
555 ;;
556esac
557AC_SUBST(THRLIBS)
558
547dnl 559dnl
548dnl Checks for header files. 560dnl Checks for header files.
549dnl 561dnl