summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 9 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index a5d4842..43fe4ad 100644
--- a/configure.in
+++ b/configure.in
@@ -1378,28 +1378,26 @@ then
1378fi 1378fi
1379 1379
1380AC_PATH_PROG(PATH_TO_FPING,fping) 1380AC_PATH_PROG(PATH_TO_FPING,fping)
1381AC_PATH_PROG(PATH_TO_FPING6,fping6)
1382
1381AC_ARG_WITH(fping_command, 1383AC_ARG_WITH(fping_command,
1382 ACX_HELP_STRING([--with-fping-command=PATH], 1384 ACX_HELP_STRING([--with-fping-command=PATH],
1383 [Path to fping command]), PATH_TO_FPING=$withval) 1385 [Path to fping command]), PATH_TO_FPING=$withval)
1386AC_ARG_WITH(fping6_command,
1387 ACX_HELP_STRING([--with-fping6-command=PATH],
1388 [Path to fping6 command]), PATH_TO_FPING6=$withval)
1389
1384if test -n "$PATH_TO_FPING" 1390if test -n "$PATH_TO_FPING"
1385then 1391then
1386 AC_DEFINE_UNQUOTED(PATH_TO_FPING,"$PATH_TO_FPING",[path to fping]) 1392 AC_DEFINE_UNQUOTED(PATH_TO_FPING,"$PATH_TO_FPING",[path to fping])
1387 EXTRAS="$EXTRAS check_fping" 1393 EXTRAS="$EXTRAS check_fping"
1394 if test x"$with_ipv6" != xno && test -n "$PATH_TO_FPING6"; then
1395 AC_DEFINE_UNQUOTED(PATH_TO_FPING6,"$PATH_TO_FPING6",[path to fping6])
1396 fi
1388else 1397else
1389 AC_MSG_WARN([Get fping from http://www.fping.com in order to make check_fping plugin]) 1398 AC_MSG_WARN([Get fping from http://www.fping.com in order to make check_fping plugin])
1390fi 1399fi
1391 1400
1392AC_PATH_PROG(PATH_TO_FPING6,fping6)
1393AC_ARG_WITH(fping6_command,
1394 ACX_HELP_STRING([--with-fping6-command=PATH],
1395 [Path to fping6 command]), PATH_TO_FPING6=$withval)
1396if test -n "$PATH_TO_FPING6"
1397then
1398 AC_DEFINE_UNQUOTED(PATH_TO_FPING6,"$PATH_TO_FPING6",[path to fping6])
1399else
1400 AC_MSG_WARN([Get fping6 from http://www.fping.com in order to make check_fping plugin])
1401fi
1402
1403AC_PATH_PROG(PATH_TO_SSH,ssh) 1401AC_PATH_PROG(PATH_TO_SSH,ssh)
1404AC_ARG_WITH(ssh_command, 1402AC_ARG_WITH(ssh_command,
1405 ACX_HELP_STRING([--with-ssh-command=PATH], 1403 ACX_HELP_STRING([--with-ssh-command=PATH],