summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 9 insertions, 13 deletions
diff --git a/configure.in b/configure.in
index a6261c6..5c067b4 100644
--- a/configure.in
+++ b/configure.in
@@ -1,23 +1,18 @@
1dnl Process this file with autoconf to produce a configure script. 1dnl Process this file with autoconf to produce a configure script.
2AC_REVISION ($Revision$) 2AC_REVISION ($Revision$)
3AC_PREREQ(2.50) 3AC_PREREQ(2.50)
4AC_INIT(Helper.pm) 4AC_INIT(nagios-plugins,1.3.99)
5VER=1.3.99 5AC_CONFIG_SRCDIR(Helper.pm)
6REL=1 6AM_INIT_AUTOMAKE
7AC_SUBST(VER)
8AC_SUBST(REL)
9PACKAGE_VERSION="${VER}"
10AC_SUBST(PACKAGE_VERSION)
11PACKAGE_RELEASE="${REL}"
12AC_SUBST(PACKAGE_RELEASE)
13AM_INIT_AUTOMAKE(nagios-plugins,${PACKAGE_VERSION})
14AM_CONFIG_HEADER(plugins/config.h) 7AM_CONFIG_HEADER(plugins/config.h)
15AC_CANONICAL_HOST 8AC_CANONICAL_HOST
16 9
10RELEASE=1
11AC_SUBST(RELEASE)
12
17AC_PREFIX_DEFAULT(/usr/local/nagios) 13AC_PREFIX_DEFAULT(/usr/local/nagios)
18 14
19dnl Figure out how to invoke "install" and what install options to use. 15dnl Figure out how to invoke "install" and what install options to use.
20
21AC_PROG_INSTALL 16AC_PROG_INSTALL
22AC_SUBST(INSTALL) 17AC_SUBST(INSTALL)
23 18
@@ -1394,9 +1389,10 @@ AC_SUBST(EXTRAS)
1394AC_SUBST(EXTRA_NETOBJS) 1389AC_SUBST(EXTRA_NETOBJS)
1395AC_SUBST(DEPLIBS) 1390AC_SUBST(DEPLIBS)
1396 1391
1397AC_DEFINE_UNQUOTED(PACKAGE_VERSION,"${VERSION}",[package version]) 1392GETTEXT_VERSION=0.11.4
1393AM_GNU_GETTEXT
1398 1394
1399AC_OUTPUT(Makefile lib/Makefile plugins/Makefile plugins-scripts/Makefile plugins-scripts/subst plugins-scripts/utils.pm plugins-scripts/utils.sh command.cfg test.pl pkg/solaris/pkginfo) 1395AC_OUTPUT(Makefile lib/Makefile plugins/Makefile plugins-scripts/Makefile plugins-scripts/subst plugins-scripts/utils.pm plugins-scripts/utils.sh command.cfg test.pl pkg/solaris/pkginfo intl/Makefile po/Makefile.in )
1400 1396
1401ACX_FEATURE([with],[cgiurl]) 1397ACX_FEATURE([with],[cgiurl])
1402ACX_FEATURE([with],[nagios-user]) 1398ACX_FEATURE([with],[nagios-user])