summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 5453fe1..4f9dc1c 100644
--- a/configure.in
+++ b/configure.in
@@ -1520,6 +1520,22 @@ AC_SUBST(DEPLIBS)
1520AM_GNU_GETTEXT([no-libtool], [need-ngettext]) 1520AM_GNU_GETTEXT([no-libtool], [need-ngettext])
1521AM_GNU_GETTEXT_VERSION(0.11.5) 1521AM_GNU_GETTEXT_VERSION(0.11.5)
1522 1522
1523dnl Check for Redhat spopen problem
1524dnl Wierd problem where ECHILD is returned from a wait call in error
1525dnl Only appears to affect nslookup and dig calls. Only affects redhat around
1526dnl 2.6.9-11 (okay in 2.6.9-5). Redhat investigating root cause
1527dnl We patch plugins/popen.c
1528if echo $ac_cv_uname_r | egrep "\.EL$" >/dev/null 2>&1 ; then
1529 AC_MSG_CHECKING(for redhat spopen problem)
1530 ( cd config_test && make && make test ) > /dev/null 2>&1
1531 if test $? -eq 0 ; then
1532 AC_MSG_RESULT(okay)
1533 else
1534 AC_MSG_RESULT(error)
1535 AC_DEFINE(REDHAT_SPOPEN_ERROR, 1, "Problem on redhat with spopen")
1536 fi
1537fi
1538
1523dnl External libraries - see ACKNOWLEDGEMENTS 1539dnl External libraries - see ACKNOWLEDGEMENTS
1524np_COREUTILS 1540np_COREUTILS
1525np_CURL 1541np_CURL