summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 19 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index be9fe83..9303850 100644
--- a/configure.in
+++ b/configure.in
@@ -1680,17 +1680,26 @@ dnl Wierd problem where ECHILD is returned from a wait call in error
1680dnl Only appears to affect nslookup and dig calls. Only affects redhat around 1680dnl Only appears to affect nslookup and dig calls. Only affects redhat around
1681dnl 2.6.9-11 (okay in 2.6.9-5). Redhat investigating root cause 1681dnl 2.6.9-11 (okay in 2.6.9-5). Redhat investigating root cause
1682dnl We patch plugins/popen.c 1682dnl We patch plugins/popen.c
1683dnl Need to add smp because uname different on those. May need to check 1683dnl Need to add smp because uname different on those
1684dnl Fedora Core too in future 1684dnl Can force patch to be applied with --enable-redhat-pthread-workaround
1685if echo $ac_cv_uname_r | egrep "\.EL(smp)?$" >/dev/null 2>&1 ; then 1685AC_ARG_ENABLE(redhat-pthread-workaround,
1686 AC_MSG_CHECKING(for redhat spopen problem) 1686 AC_HELP_STRING([--enable-redhat-pthread-workaround],
1687 ( cd config_test && make && make test ) > /dev/null 2>&1 1687 [force Redhat patch to be applied (default: test system)]),
1688 if test $? -eq 0 ; then 1688 [ac_cv_enable_redhat_pthread_workaround=$enableval],
1689 AC_MSG_RESULT(okay) 1689 [ac_cv_enable_redhat_pthread_workaround=test])
1690 else 1690if test "$ac_cv_enable_redhat_pthread_workaround" = "test" ; then
1691 AC_MSG_RESULT(error) 1691 if echo $ac_cv_uname_r | egrep "\.EL(smp)?$" >/dev/null 2>&1 ; then
1692 AC_DEFINE(REDHAT_SPOPEN_ERROR, 1, "Problem on redhat with spopen") 1692 AC_MSG_CHECKING(for redhat spopen problem)
1693 ( cd config_test && make && make test ) > /dev/null 2>&1
1694 if test $? -eq 0 ; then
1695 AC_MSG_RESULT(okay)
1696 else
1697 AC_MSG_RESULT(error)
1698 AC_DEFINE(REDHAT_SPOPEN_ERROR, 1, [Workaround on redhat in spopen])
1699 fi
1693 fi 1700 fi
1701elif test "$ac_cv_enable_redhat_pthread_workaround" = "yes" ; then
1702 AC_DEFINE(REDHAT_SPOPEN_ERROR, 1, [Forced workaround on redhat in spopen])
1694fi 1703fi
1695 1704
1696dnl External libraries - see ACKNOWLEDGEMENTS 1705dnl External libraries - see ACKNOWLEDGEMENTS