summaryrefslogtreecommitdiffstats
path: root/gl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gl/Makefile.am')
-rw-r--r--gl/Makefile.am63
1 files changed, 56 insertions, 7 deletions
diff --git a/gl/Makefile.am b/gl/Makefile.am
index cae814f..87fe031 100644
--- a/gl/Makefile.am
+++ b/gl/Makefile.am
@@ -28,6 +28,7 @@ MAINTAINERCLEANFILES =
28EXTRA_DIST += m4/gnulib-cache.m4 28EXTRA_DIST += m4/gnulib-cache.m4
29 29
30AM_CPPFLAGS = 30AM_CPPFLAGS =
31AM_CFLAGS =
31 32
32noinst_LIBRARIES += libgnu.a 33noinst_LIBRARIES += libgnu.a
33 34
@@ -36,6 +37,13 @@ libgnu_a_LIBADD = $(gl_LIBOBJS)
36libgnu_a_DEPENDENCIES = $(gl_LIBOBJS) 37libgnu_a_DEPENDENCIES = $(gl_LIBOBJS)
37EXTRA_libgnu_a_SOURCES = 38EXTRA_libgnu_a_SOURCES =
38 39
40## begin gnulib module alignof
41
42
43EXTRA_DIST += alignof.h
44
45## end gnulib module alignof
46
39## begin gnulib module alloca 47## begin gnulib module alloca
40 48
41 49
@@ -70,7 +78,7 @@ BUILT_SOURCES += $(ARPA_INET_H)
70 78
71# We need the following in order to create <arpa/inet.h> when the system 79# We need the following in order to create <arpa/inet.h> when the system
72# doesn't have one. 80# doesn't have one.
73arpa/inet.h: 81arpa/inet.h: arpa_inet.in.h
74 @MKDIR_P@ arpa 82 @MKDIR_P@ arpa
75 rm -f $@-t $@ 83 rm -f $@-t $@
76 { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \ 84 { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \
@@ -146,7 +154,7 @@ EXTRA_libgnu_a_SOURCES += cloexec.c
146# The Automake-defined pkg* macros are appended, in the order 154# The Automake-defined pkg* macros are appended, in the order
147# listed in the Automake 1.10a+ documentation. 155# listed in the Automake 1.10a+ documentation.
148configmake.h: Makefile 156configmake.h: Makefile
149 rm -f $@-t $@ 157 rm -f $@-t
150 { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \ 158 { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \
151 echo '#define PREFIX "$(prefix)"'; \ 159 echo '#define PREFIX "$(prefix)"'; \
152 echo '#define EXEC_PREFIX "$(exec_prefix)"'; \ 160 echo '#define EXEC_PREFIX "$(exec_prefix)"'; \
@@ -176,7 +184,12 @@ configmake.h: Makefile
176 echo '#define PKGLIBDIR "$(pkglibdir)"'; \ 184 echo '#define PKGLIBDIR "$(pkglibdir)"'; \
177 echo '#define PKGLIBEXECDIR "$(pkglibexecdir)"'; \ 185 echo '#define PKGLIBEXECDIR "$(pkglibexecdir)"'; \
178 } | sed '/""/d' > $@-t 186 } | sed '/""/d' > $@-t
179 mv $@-t $@ 187 if test -f $@ && cmp $@-t $@ > /dev/null; then \
188 rm -f $@-t; \
189 else \
190 rm -f $@; mv $@-t $@; \
191 fi
192
180BUILT_SOURCES += configmake.h 193BUILT_SOURCES += configmake.h
181CLEANFILES += configmake.h configmake.h-t 194CLEANFILES += configmake.h configmake.h-t
182 195
@@ -433,21 +446,37 @@ all-local: charset.alias ref-add.sed ref-del.sed
433 446
434charset_alias = $(DESTDIR)$(libdir)/charset.alias 447charset_alias = $(DESTDIR)$(libdir)/charset.alias
435charset_tmp = $(DESTDIR)$(libdir)/charset.tmp 448charset_tmp = $(DESTDIR)$(libdir)/charset.tmp
436install-exec-local: all-local 449install-exec-local: install-exec-localcharset
437 test $(GLIBC21) != no || $(mkinstalldirs) $(DESTDIR)$(libdir) 450install-exec-localcharset: all-local
451 if test $(GLIBC21) = no; then \
452 case '$(host_os)' in \
453 darwin[56]*) \
454 need_charset_alias=true ;; \
455 darwin* | cygwin* | mingw* | pw32* | cegcc*) \
456 need_charset_alias=false ;; \
457 *) \
458 need_charset_alias=true ;; \
459 esac ; \
460 else \
461 need_charset_alias=false ; \
462 fi ; \
463 if $$need_charset_alias; then \
464 $(mkinstalldirs) $(DESTDIR)$(libdir) ; \
465 fi ; \
438 if test -f $(charset_alias); then \ 466 if test -f $(charset_alias); then \
439 sed -f ref-add.sed $(charset_alias) > $(charset_tmp) ; \ 467 sed -f ref-add.sed $(charset_alias) > $(charset_tmp) ; \
440 $(INSTALL_DATA) $(charset_tmp) $(charset_alias) ; \ 468 $(INSTALL_DATA) $(charset_tmp) $(charset_alias) ; \
441 rm -f $(charset_tmp) ; \ 469 rm -f $(charset_tmp) ; \
442 else \ 470 else \
443 if test $(GLIBC21) = no; then \ 471 if $$need_charset_alias; then \
444 sed -f ref-add.sed charset.alias > $(charset_tmp) ; \ 472 sed -f ref-add.sed charset.alias > $(charset_tmp) ; \
445 $(INSTALL_DATA) $(charset_tmp) $(charset_alias) ; \ 473 $(INSTALL_DATA) $(charset_tmp) $(charset_alias) ; \
446 rm -f $(charset_tmp) ; \ 474 rm -f $(charset_tmp) ; \
447 fi ; \ 475 fi ; \
448 fi 476 fi
449 477
450uninstall-local: all-local 478uninstall-local: uninstall-localcharset
479uninstall-localcharset: all-local
451 if test -f $(charset_alias); then \ 480 if test -f $(charset_alias); then \
452 sed -f ref-del.sed $(charset_alias) > $(charset_tmp); \ 481 sed -f ref-del.sed $(charset_alias) > $(charset_tmp); \
453 if grep '^# Packages using this file: $$' $(charset_tmp) \ 482 if grep '^# Packages using this file: $$' $(charset_tmp) \
@@ -794,6 +823,8 @@ stdio.h: stdio.in.h
794 -e 's|@''GNULIB_VPRINTF_POSIX''@|$(GNULIB_VPRINTF_POSIX)|g' \ 823 -e 's|@''GNULIB_VPRINTF_POSIX''@|$(GNULIB_VPRINTF_POSIX)|g' \
795 -e 's|@''GNULIB_VSNPRINTF''@|$(GNULIB_VSNPRINTF)|g' \ 824 -e 's|@''GNULIB_VSNPRINTF''@|$(GNULIB_VSNPRINTF)|g' \
796 -e 's|@''GNULIB_VSPRINTF_POSIX''@|$(GNULIB_VSPRINTF_POSIX)|g' \ 825 -e 's|@''GNULIB_VSPRINTF_POSIX''@|$(GNULIB_VSPRINTF_POSIX)|g' \
826 -e 's|@''GNULIB_DPRINTF''@|$(GNULIB_DPRINTF)|g' \
827 -e 's|@''GNULIB_VDPRINTF''@|$(GNULIB_VDPRINTF)|g' \
797 -e 's|@''GNULIB_VASPRINTF''@|$(GNULIB_VASPRINTF)|g' \ 828 -e 's|@''GNULIB_VASPRINTF''@|$(GNULIB_VASPRINTF)|g' \
798 -e 's|@''GNULIB_OBSTACK_PRINTF''@|$(GNULIB_OBSTACK_PRINTF)|g' \ 829 -e 's|@''GNULIB_OBSTACK_PRINTF''@|$(GNULIB_OBSTACK_PRINTF)|g' \
799 -e 's|@''GNULIB_OBSTACK_PRINTF_POSIX''@|$(GNULIB_OBSTACK_PRINTF_POSIX)|g' \ 830 -e 's|@''GNULIB_OBSTACK_PRINTF_POSIX''@|$(GNULIB_OBSTACK_PRINTF_POSIX)|g' \
@@ -826,6 +857,10 @@ stdio.h: stdio.in.h
826 -e 's|@''HAVE_DECL_VSNPRINTF''@|$(HAVE_DECL_VSNPRINTF)|g' \ 857 -e 's|@''HAVE_DECL_VSNPRINTF''@|$(HAVE_DECL_VSNPRINTF)|g' \
827 -e 's|@''REPLACE_SPRINTF''@|$(REPLACE_SPRINTF)|g' \ 858 -e 's|@''REPLACE_SPRINTF''@|$(REPLACE_SPRINTF)|g' \
828 -e 's|@''REPLACE_VSPRINTF''@|$(REPLACE_VSPRINTF)|g' \ 859 -e 's|@''REPLACE_VSPRINTF''@|$(REPLACE_VSPRINTF)|g' \
860 -e 's|@''HAVE_DPRINTF''@|$(HAVE_DPRINTF)|g' \
861 -e 's|@''REPLACE_DPRINTF''@|$(REPLACE_DPRINTF)|g' \
862 -e 's|@''HAVE_VDPRINTF''@|$(HAVE_VDPRINTF)|g' \
863 -e 's|@''REPLACE_VDPRINTF''@|$(REPLACE_VDPRINTF)|g' \
829 -e 's|@''HAVE_VASPRINTF''@|$(HAVE_VASPRINTF)|g' \ 864 -e 's|@''HAVE_VASPRINTF''@|$(HAVE_VASPRINTF)|g' \
830 -e 's|@''REPLACE_VASPRINTF''@|$(REPLACE_VASPRINTF)|g' \ 865 -e 's|@''REPLACE_VASPRINTF''@|$(REPLACE_VASPRINTF)|g' \
831 -e 's|@''HAVE_DECL_OBSTACK_PRINTF''@|$(HAVE_DECL_OBSTACK_PRINTF)|g' \ 866 -e 's|@''HAVE_DECL_OBSTACK_PRINTF''@|$(HAVE_DECL_OBSTACK_PRINTF)|g' \
@@ -866,6 +901,7 @@ stdlib.h: stdlib.in.h
866 sed -e 's|@''INCLUDE_NEXT''@|$(INCLUDE_NEXT)|g' \ 901 sed -e 's|@''INCLUDE_NEXT''@|$(INCLUDE_NEXT)|g' \
867 -e 's|@''PRAGMA_SYSTEM_HEADER''@|@PRAGMA_SYSTEM_HEADER@|g' \ 902 -e 's|@''PRAGMA_SYSTEM_HEADER''@|@PRAGMA_SYSTEM_HEADER@|g' \
868 -e 's|@''NEXT_STDLIB_H''@|$(NEXT_STDLIB_H)|g' \ 903 -e 's|@''NEXT_STDLIB_H''@|$(NEXT_STDLIB_H)|g' \
904 -e 's|@''HAVE_RANDOM_H''@|$(HAVE_RANDOM_H)|g' \
869 -e 's|@''GNULIB_MALLOC_POSIX''@|$(GNULIB_MALLOC_POSIX)|g' \ 905 -e 's|@''GNULIB_MALLOC_POSIX''@|$(GNULIB_MALLOC_POSIX)|g' \
870 -e 's|@''GNULIB_REALLOC_POSIX''@|$(GNULIB_REALLOC_POSIX)|g' \ 906 -e 's|@''GNULIB_REALLOC_POSIX''@|$(GNULIB_REALLOC_POSIX)|g' \
871 -e 's|@''GNULIB_CALLOC_POSIX''@|$(GNULIB_CALLOC_POSIX)|g' \ 907 -e 's|@''GNULIB_CALLOC_POSIX''@|$(GNULIB_CALLOC_POSIX)|g' \
@@ -912,6 +948,15 @@ EXTRA_DIST += stdlib.in.h
912 948
913## end gnulib module stdlib 949## end gnulib module stdlib
914 950
951## begin gnulib module strdup-posix
952
953
954EXTRA_DIST += strdup.c
955
956EXTRA_libgnu_a_SOURCES += strdup.c
957
958## end gnulib module strdup-posix
959
915## begin gnulib module streq 960## begin gnulib module streq
916 961
917 962
@@ -1054,6 +1099,7 @@ sys/socket.h: sys_socket.in.h
1054 -e 's|@''GNULIB_SHUTDOWN''@|$(GNULIB_SHUTDOWN)|g' \ 1099 -e 's|@''GNULIB_SHUTDOWN''@|$(GNULIB_SHUTDOWN)|g' \
1055 -e 's|@''HAVE_WINSOCK2_H''@|$(HAVE_WINSOCK2_H)|g' \ 1100 -e 's|@''HAVE_WINSOCK2_H''@|$(HAVE_WINSOCK2_H)|g' \
1056 -e 's|@''HAVE_WS2TCPIP_H''@|$(HAVE_WS2TCPIP_H)|g' \ 1101 -e 's|@''HAVE_WS2TCPIP_H''@|$(HAVE_WS2TCPIP_H)|g' \
1102 -e 's|@''HAVE_STRUCT_SOCKADDR_STORAGE''@|$(HAVE_STRUCT_SOCKADDR_STORAGE)|g' \
1057 -e '/definition of GL_LINK_WARNING/r $(LINK_WARNING_H)' \ 1103 -e '/definition of GL_LINK_WARNING/r $(LINK_WARNING_H)' \
1058 < $(srcdir)/sys_socket.in.h; \ 1104 < $(srcdir)/sys_socket.in.h; \
1059 } > $@-t 1105 } > $@-t
@@ -1139,6 +1185,7 @@ unistd.h: unistd.in.h
1139 -e 's|@''GNULIB_GETPAGESIZE''@|$(GNULIB_GETPAGESIZE)|g' \ 1185 -e 's|@''GNULIB_GETPAGESIZE''@|$(GNULIB_GETPAGESIZE)|g' \
1140 -e 's|@''GNULIB_GETUSERSHELL''@|$(GNULIB_GETUSERSHELL)|g' \ 1186 -e 's|@''GNULIB_GETUSERSHELL''@|$(GNULIB_GETUSERSHELL)|g' \
1141 -e 's|@''GNULIB_LCHOWN''@|$(GNULIB_LCHOWN)|g' \ 1187 -e 's|@''GNULIB_LCHOWN''@|$(GNULIB_LCHOWN)|g' \
1188 -e 's|@''GNULIB_LINK''@|$(GNULIB_LINK)|g' \
1142 -e 's|@''GNULIB_LSEEK''@|$(GNULIB_LSEEK)|g' \ 1189 -e 's|@''GNULIB_LSEEK''@|$(GNULIB_LSEEK)|g' \
1143 -e 's|@''GNULIB_READLINK''@|$(GNULIB_READLINK)|g' \ 1190 -e 's|@''GNULIB_READLINK''@|$(GNULIB_READLINK)|g' \
1144 -e 's|@''GNULIB_SLEEP''@|$(GNULIB_SLEEP)|g' \ 1191 -e 's|@''GNULIB_SLEEP''@|$(GNULIB_SLEEP)|g' \
@@ -1153,6 +1200,7 @@ unistd.h: unistd.in.h
1153 -e 's|@''HAVE_GETHOSTNAME''@|$(HAVE_GETHOSTNAME)|g' \ 1200 -e 's|@''HAVE_GETHOSTNAME''@|$(HAVE_GETHOSTNAME)|g' \
1154 -e 's|@''HAVE_GETPAGESIZE''@|$(HAVE_GETPAGESIZE)|g' \ 1201 -e 's|@''HAVE_GETPAGESIZE''@|$(HAVE_GETPAGESIZE)|g' \
1155 -e 's|@''HAVE_GETUSERSHELL''@|$(HAVE_GETUSERSHELL)|g' \ 1202 -e 's|@''HAVE_GETUSERSHELL''@|$(HAVE_GETUSERSHELL)|g' \
1203 -e 's|@''HAVE_LINK''@|$(HAVE_LINK)|g' \
1156 -e 's|@''HAVE_READLINK''@|$(HAVE_READLINK)|g' \ 1204 -e 's|@''HAVE_READLINK''@|$(HAVE_READLINK)|g' \
1157 -e 's|@''HAVE_SLEEP''@|$(HAVE_SLEEP)|g' \ 1205 -e 's|@''HAVE_SLEEP''@|$(HAVE_SLEEP)|g' \
1158 -e 's|@''HAVE_DECL_ENVIRON''@|$(HAVE_DECL_ENVIRON)|g' \ 1206 -e 's|@''HAVE_DECL_ENVIRON''@|$(HAVE_DECL_ENVIRON)|g' \
@@ -1266,6 +1314,7 @@ wchar.h: wchar.in.h
1266 -e 's|@''REPLACE_MBSNRTOWCS''@|$(REPLACE_MBSNRTOWCS)|g' \ 1314 -e 's|@''REPLACE_MBSNRTOWCS''@|$(REPLACE_MBSNRTOWCS)|g' \
1267 -e 's|@''REPLACE_WCRTOMB''@|$(REPLACE_WCRTOMB)|g' \ 1315 -e 's|@''REPLACE_WCRTOMB''@|$(REPLACE_WCRTOMB)|g' \
1268 -e 's|@''REPLACE_WCSRTOMBS''@|$(REPLACE_WCSRTOMBS)|g' \ 1316 -e 's|@''REPLACE_WCSRTOMBS''@|$(REPLACE_WCSRTOMBS)|g' \
1317 -e 's|@''REPLACE_WCSNRTOMBS''@|$(REPLACE_WCSNRTOMBS)|g' \
1269 -e 's|@''REPLACE_WCWIDTH''@|$(REPLACE_WCWIDTH)|g' \ 1318 -e 's|@''REPLACE_WCWIDTH''@|$(REPLACE_WCWIDTH)|g' \
1270 -e '/definition of GL_LINK_WARNING/r $(LINK_WARNING_H)' \ 1319 -e '/definition of GL_LINK_WARNING/r $(LINK_WARNING_H)' \
1271 < $(srcdir)/wchar.in.h; \ 1320 < $(srcdir)/wchar.in.h; \