summaryrefslogtreecommitdiffstats
path: root/gl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gl/Makefile.am')
-rw-r--r--gl/Makefile.am42
1 files changed, 41 insertions, 1 deletions
diff --git a/gl/Makefile.am b/gl/Makefile.am
index c2e8e5a..4339b2c 100644
--- a/gl/Makefile.am
+++ b/gl/Makefile.am
@@ -21,7 +21,7 @@
21# the same distribution terms as the rest of that program. 21# the same distribution terms as the rest of that program.
22# 22#
23# Generated by gnulib-tool. 23# Generated by gnulib-tool.
24# Reproduce by: gnulib-tool --import --dir=. --lib=libgnu --source-base=gl --m4-base=gl/m4 --doc-base=doc --tests-base=tests --aux-dir=build-aux --no-conditional-dependencies --no-libtool --macro-prefix=gl --no-vc-files base64 crypto/sha1 dirname environ floorf fsusage getaddrinfo gethostname getloadavg getopt-gnu gettext mountlist regex setenv strsep timegm unsetenv vasprintf vsnprintf 24# Reproduce by: gnulib-tool --import --dir=. --lib=libgnu --source-base=gl --m4-base=gl/m4 --doc-base=doc --tests-base=tests --aux-dir=build-aux --no-conditional-dependencies --no-libtool --macro-prefix=gl --no-vc-files base64 crypto/sha1 dirname environ floorf fsusage getaddrinfo gethostname getloadavg getopt-gnu gettext mountlist regex setenv strcase strsep timegm unsetenv vasprintf vsnprintf
25 25
26AUTOMAKE_OPTIONS = 1.9.6 gnits subdir-objects 26AUTOMAKE_OPTIONS = 1.9.6 gnits subdir-objects
27 27
@@ -1536,6 +1536,15 @@ EXTRA_DIST += stdlib.in.h
1536 1536
1537## end gnulib module stdlib 1537## end gnulib module stdlib
1538 1538
1539## begin gnulib module strcase
1540
1541
1542EXTRA_DIST += strcasecmp.c strncasecmp.c
1543
1544EXTRA_libgnu_a_SOURCES += strcasecmp.c strncasecmp.c
1545
1546## end gnulib module strcase
1547
1539## begin gnulib module streq 1548## begin gnulib module streq
1540 1549
1541 1550
@@ -1661,6 +1670,37 @@ EXTRA_DIST += string.in.h
1661 1670
1662## end gnulib module string 1671## end gnulib module string
1663 1672
1673## begin gnulib module strings
1674
1675BUILT_SOURCES += strings.h
1676
1677# We need the following in order to create <strings.h> when the system
1678# doesn't have one that works with the given compiler.
1679strings.h: strings.in.h $(top_builddir)/config.status $(CXXDEFS_H) $(WARN_ON_USE_H) $(ARG_NONNULL_H)
1680 $(AM_V_GEN)rm -f $@-t $@ && \
1681 { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */' && \
1682 sed -e 's|@''GUARD_PREFIX''@|GL|g' \
1683 -e 's|@''HAVE_STRINGS_H''@|$(HAVE_STRINGS_H)|g' \
1684 -e 's|@''INCLUDE_NEXT''@|$(INCLUDE_NEXT)|g' \
1685 -e 's|@''PRAGMA_SYSTEM_HEADER''@|@PRAGMA_SYSTEM_HEADER@|g' \
1686 -e 's|@''PRAGMA_COLUMNS''@|@PRAGMA_COLUMNS@|g' \
1687 -e 's|@''NEXT_STRINGS_H''@|$(NEXT_STRINGS_H)|g' \
1688 -e 's|@''GNULIB_FFS''@|$(GNULIB_FFS)|g' \
1689 -e 's|@''HAVE_FFS''@|$(HAVE_FFS)|g' \
1690 -e 's|@''HAVE_STRCASECMP''@|$(HAVE_STRCASECMP)|g' \
1691 -e 's|@''HAVE_DECL_STRNCASECMP''@|$(HAVE_DECL_STRNCASECMP)|g' \
1692 -e '/definitions of _GL_FUNCDECL_RPL/r $(CXXDEFS_H)' \
1693 -e '/definition of _GL_ARG_NONNULL/r $(ARG_NONNULL_H)' \
1694 -e '/definition of _GL_WARN_ON_USE/r $(WARN_ON_USE_H)' \
1695 < $(srcdir)/strings.in.h; \
1696 } > $@-t && \
1697 mv $@-t $@
1698MOSTLYCLEANFILES += strings.h strings.h-t
1699
1700EXTRA_DIST += strings.in.h
1701
1702## end gnulib module strings
1703
1664## begin gnulib module strndup 1704## begin gnulib module strndup
1665 1705
1666 1706