summaryrefslogtreecommitdiffstats
path: root/plugins-root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins-root/Makefile.am')
-rw-r--r--plugins-root/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/plugins-root/Makefile.am b/plugins-root/Makefile.am
index 107d993..de8813f 100644
--- a/plugins-root/Makefile.am
+++ b/plugins-root/Makefile.am
@@ -1,5 +1,11 @@
1## Process this file with automake to produce Makefile.in 1## Process this file with automake to produce Makefile.in
2 2
3NP-VERSION-FILE: .FORCE-NP-VERSION-FILE
4 @$(SHELL_PATH) $(top_srcdir)/NP-VERSION-GEN
5-include NP-VERSION-FILE
6
7AM_CFLAGS = -DNP_VERSION='"$(NP_VERSION)"'
8
3VPATH = $(top_srcdir) $(top_srcdir)/lib $(top_srcdir)/plugins $(top_srcdir)/plugins/t $(srcdir) 9VPATH = $(top_srcdir) $(top_srcdir)/lib $(top_srcdir)/plugins $(top_srcdir)/plugins/t $(srcdir)
4 10
5INCLUDES = -I.. -I$(top_srcdir)/lib -I$(top_srcdir)/gl -I$(top_srcdir)/intl -I$(top_srcdir)/plugins @SSLINCLUDE@ 11INCLUDES = -I.. -I$(top_srcdir)/lib -I$(top_srcdir)/gl -I$(top_srcdir)/intl -I$(top_srcdir)/plugins @SSLINCLUDE@
@@ -74,3 +80,10 @@ pst3_LDFLAGS = @PST3CFLAGS@
74 80
75check_dhcp_DEPENDENCIES = check_dhcp.c $(NETOBJS) $(DEPLIBS) 81check_dhcp_DEPENDENCIES = check_dhcp.c $(NETOBJS) $(DEPLIBS)
76check_icmp_DEPENDENCIES = check_icmp.c $(NETOBJS) 82check_icmp_DEPENDENCIES = check_icmp.c $(NETOBJS)
83
84all-local: .FORCE-NP-VERSION-FILE
85
86clean-local:
87 rm -f NP-VERSION-FILE
88
89.PHONY: .FORCE-NP-VERSION-FILE