summaryrefslogtreecommitdiffstats
path: root/plugins-scripts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins-scripts/Makefile.am')
-rw-r--r--plugins-scripts/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/plugins-scripts/Makefile.am b/plugins-scripts/Makefile.am
index 4ea262a..78a950c 100644
--- a/plugins-scripts/Makefile.am
+++ b/plugins-scripts/Makefile.am
@@ -23,6 +23,11 @@ EXTRA_DIST=check_breeze.pl check_disk_smb.pl check_flexlm.pl check_ircd.pl \
23 check_ifstatus.pl check_ifoperstatus.pl check_wave.pl check_mailq.pl check_file_age.pl \ 23 check_ifstatus.pl check_ifoperstatus.pl check_wave.pl check_mailq.pl check_file_age.pl \
24 utils.sh.in utils.pm.in t 24 utils.sh.in utils.pm.in t
25 25
26EDIT = sed \
27 -e 's|[@]NP_VERSION[@]|$(NP_VERSION)|g' \
28 -e 's|[@]TRUSTED_PATH[@]|$(with_trusted_path)|g' \
29 -e 's|[@]PERL[@]|$(PERL)|g'
30
26TESTS_ENVIRONMENT=perl -I $(top_builddir) -I $(top_srcdir) 31TESTS_ENVIRONMENT=perl -I $(top_builddir) -I $(top_srcdir)
27 32
28TESTS = @SCRIPT_TEST@ 33TESTS = @SCRIPT_TEST@
@@ -38,11 +43,11 @@ test-debug:
38CLEANFILES=$(libexec_SCRIPTS) 43CLEANFILES=$(libexec_SCRIPTS)
39 44
40.pl : 45.pl :
41 NP_VERSION=$(NP_VERSION) $(AWK) -f ./subst $< > $@ 46 $(EDIT) $< > $@
42 chmod +x $@ 47 chmod +x $@
43 48
44.sh : 49.sh :
45 NP_VERSION=$(NP_VERSION) $(AWK) -f ./subst $< > $@ 50 $(EDIT) $< > $@
46 chmod +x $@ 51 chmod +x $@
47 52
48clean-local: 53clean-local: