[Nagiosplug-devel] Feature Request: Check_cluster2

Matthias Eble matthias.eble at mailing.kaufland-informationssysteme.com
Thu Apr 12 16:49:05 CEST 2007

Hi All,
> Note however that this will slightly change the definition of a single
> number on the command line. In the current check it meant " >= x" while
> with the official threshold format it will mean " < 0 or > x". For
> example to alert as soon as one service is down you will need to use "0"
> instead of "1".

I geuss there was a discussion about threshold format, a couple of weeks 
ago. I think the consens was, to include the unified format in a 2.0 
release, is that right? So should we decide about the new range format 

I'd really like to implement it, if everybody is fine with it, but I'll 
go on vacation on Saturday and will likely be offline for two weeks. 
Maybe I can get it to work until tomorrow. I'll post a message if the 
time is not enough. So eg Thomas can do it in the meantime.

Test cases should be, like Ton already said, no problem.

The name should be changed, in my opinion, too.
I like check_states. check_cluster is to special to me since the checked 
services/hosts only _might_ be part of a "Cluster".

One more thing: Check_cluster is also mentioned in the nagios docs..
this should be considered when renaming.


More information about the Devel mailing list