summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 1368780..367e82a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -500,15 +500,15 @@ if ! test x"$with_openssl" = x"no"; then
500 dnl Check for crypto lib 500 dnl Check for crypto lib
501 _SAVEDLIBS="$LIBS" 501 _SAVEDLIBS="$LIBS"
502 LIBS="-L${with_openssl}/lib" 502 LIBS="-L${with_openssl}/lib"
503 AC_CHECK_LIB(crypto,CRYPTO_lock) 503 AC_CHECK_LIB(crypto,CRYPTO_new_ex_data)
504 if test "$ac_cv_lib_crypto_CRYPTO_lock" = "yes"; then 504 if test "$ac_cv_lib_crypto_CRYPTO_new_ex_data" = "yes"; then
505 dnl Check for SSL lib 505 dnl Check for SSL lib
506 AC_CHECK_LIB(ssl,main, SSLLIBS="-lssl -lcrypto",,-lcrypto) 506 AC_CHECK_LIB(ssl,main, SSLLIBS="-lssl -lcrypto",,-lcrypto)
507 fi 507 fi
508 LIBS="$_SAVEDLIBS" 508 LIBS="$_SAVEDLIBS"
509 509
510 dnl test headers and libs to decide whether check_http should use SSL 510 dnl test headers and libs to decide whether check_http should use SSL
511 if test "$ac_cv_lib_crypto_CRYPTO_lock" = "yes"; then 511 if test "$ac_cv_lib_crypto_CRYPTO_new_ex_data" = "yes"; then
512 if test "$ac_cv_lib_ssl_main" = "yes"; then 512 if test "$ac_cv_lib_ssl_main" = "yes"; then
513 if test "$FOUNDINCLUDE" = "yes"; then 513 if test "$FOUNDINCLUDE" = "yes"; then
514 FOUNDOPENSSL="yes" 514 FOUNDOPENSSL="yes"