summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHolger Weiss <holger@zedat.fu-berlin.de>2016-11-18 10:51:12 (GMT)
committerHolger Weiss <holger@zedat.fu-berlin.de>2016-11-18 10:51:12 (GMT)
commit303acfc64f2f656729bde803a410a10a80a76b40 (patch)
tree9bcc6015490531921ad5794ac55382a3a0aa96ee /configure.ac
parent1723a3c7610cc43438c51d1e5fed43e15099a60e (diff)
parentfe1c4bb0e5ea3632d608a6b8b7e51d580856d833 (diff)
downloadmonitoring-plugins-303acfc64f2f656729bde803a410a10a80a76b40.tar.gz
Merge remote-tracking branch 'monitoring-plugins/pr/1443'
* monitoring-plugins/pr/1443: add openssl 1.1 support
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 1368780..367e82a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -500,15 +500,15 @@ if ! test x"$with_openssl" = x"no"; then
500 dnl Check for crypto lib 500 dnl Check for crypto lib
501 _SAVEDLIBS="$LIBS" 501 _SAVEDLIBS="$LIBS"
502 LIBS="-L${with_openssl}/lib" 502 LIBS="-L${with_openssl}/lib"
503 AC_CHECK_LIB(crypto,CRYPTO_lock) 503 AC_CHECK_LIB(crypto,CRYPTO_new_ex_data)
504 if test "$ac_cv_lib_crypto_CRYPTO_lock" = "yes"; then 504 if test "$ac_cv_lib_crypto_CRYPTO_new_ex_data" = "yes"; then
505 dnl Check for SSL lib 505 dnl Check for SSL lib
506 AC_CHECK_LIB(ssl,main, SSLLIBS="-lssl -lcrypto",,-lcrypto) 506 AC_CHECK_LIB(ssl,main, SSLLIBS="-lssl -lcrypto",,-lcrypto)
507 fi 507 fi
508 LIBS="$_SAVEDLIBS" 508 LIBS="$_SAVEDLIBS"
509 509
510 dnl test headers and libs to decide whether check_http should use SSL 510 dnl test headers and libs to decide whether check_http should use SSL
511 if test "$ac_cv_lib_crypto_CRYPTO_lock" = "yes"; then 511 if test "$ac_cv_lib_crypto_CRYPTO_new_ex_data" = "yes"; then
512 if test "$ac_cv_lib_ssl_main" = "yes"; then 512 if test "$ac_cv_lib_ssl_main" = "yes"; then
513 if test "$FOUNDINCLUDE" = "yes"; then 513 if test "$FOUNDINCLUDE" = "yes"; then
514 FOUNDOPENSSL="yes" 514 FOUNDOPENSSL="yes"